Вопрос задан 06.04.2019 в 01:35.
Предмет Информатика.
Спрашивает Умникова Анастасия.
Написать программу в PascalABC!!!Число в двоичной системе счисления, введенное пользователем
программы, преобразовать в десятичное число.Ответы на вопрос
Отвечает Grishko Daria.
Var a:string;
i,a1,ar:integer;b:real;
begin
readln(a);
b:=0;
for i:=1 to length(a) do
begin
val(a[length(a)-i+1],a1,ar);
b:=b+a1*exp((i-1)*ln(2));
end;
writeln('b=',b);
end.
i,a1,ar:integer;b:real;
begin
readln(a);
b:=0;
for i:=1 to length(a) do
begin
val(a[length(a)-i+1],a1,ar);
b:=b+a1*exp((i-1)*ln(2));
end;
writeln('b=',b);
end.
Топ вопросов за вчера в категории Информатика
Информатика 30
Информатика 13
Информатика 32
Информатика 38
Информатика 32
Информатика 13
Информатика 28
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
