Вопрос задан 04.04.2019 в 14:12.
Предмет Информатика.
Спрашивает Гизова Анастасия.
Программа в с++ 1. Описать класс с именем MARSH, содержащую следующие, поля: • BEGST — название
начального пункта маршрута; • TERM — название конечного пункта маршрута; • NUMER — номер маршрута. 2. Написать программу, выполняющую следующие действия: • ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH; • вывод на экран информации о маршруте, номер которого введен с клавиатуры; • если таких маршрутов нет, выдать на дисплей соответствующее сообщение.Ответы на вопрос
Отвечает Фесюк Инесса.
/*
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.
*/
#include <iostream>
using namespace std;
class MARSH
{
public:
string BEGST, TERM, NUMER;
MARSH(string b, string t, string n)
: BEGST(b), TERM(t), NUMER(n)
{
}
MARSH() {}
void info() {
cout << "Маршрут №" << NUMER
<< " (" << BEGST << '-'
<< TERM << ')';
}
};
int main()
{
MARSH TRAFFIC[3];
string b, t, n;
for (int i = 0; i < 3; i++) {
cout << "Ввод данных для маршрута " << i << ':' << endl;
cout << "Название начального пункта маршрута: ";
cin >> b;
cout << "Название конечного пункта маршрута: ";
cin >> t;
cout << "Номер маршрута: ";
cin >> n;
cout << endl;
TRAFFIC[i] = MARSH(b, t, n);
}
cout << endl << "Введите номер маршрута: ";
cin >> n;
MARSH m;
for (int i = 0; i < 3; i++) {
m = TRAFFIC[i];
if (m.NUMER == n) {
m.info();
return 0;
}
}
cout << "Нет маршрута с таким номером!" << endl;
return 1;
}
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.
*/
#include <iostream>
using namespace std;
class MARSH
{
public:
string BEGST, TERM, NUMER;
MARSH(string b, string t, string n)
: BEGST(b), TERM(t), NUMER(n)
{
}
MARSH() {}
void info() {
cout << "Маршрут №" << NUMER
<< " (" << BEGST << '-'
<< TERM << ')';
}
};
int main()
{
MARSH TRAFFIC[3];
string b, t, n;
for (int i = 0; i < 3; i++) {
cout << "Ввод данных для маршрута " << i << ':' << endl;
cout << "Название начального пункта маршрута: ";
cin >> b;
cout << "Название конечного пункта маршрута: ";
cin >> t;
cout << "Номер маршрута: ";
cin >> n;
cout << endl;
TRAFFIC[i] = MARSH(b, t, n);
}
cout << endl << "Введите номер маршрута: ";
cin >> n;
MARSH m;
for (int i = 0; i < 3; i++) {
m = TRAFFIC[i];
if (m.NUMER == n) {
m.info();
return 0;
}
}
cout << "Нет маршрута с таким номером!" << endl;
return 1;
}
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
