Вопрос задан 03.04.2019 в 12:02.
Предмет Информатика.
Спрашивает Мирный Роман.
Напишите программу в паскале: найти сумму членов арифметической прогрессии , если известны ее
первый член,разность и число членов прогрессии.Ответы на вопрос
Отвечает Лєщук Вікторія.
Var a,b,c,k:real;
begin;
write('Введите первое число прогрессии:');
readln(a);
write('Введите разность прогрессии:');
readln(b);
write('Введите число членов прогрессии:');
readln(c);
k:=((2*a+b*(c-1))/2)*c;
writeln(k);
end.
begin;
write('Введите первое число прогрессии:');
readln(a);
write('Введите разность прогрессии:');
readln(b);
write('Введите число членов прогрессии:');
readln(c);
k:=((2*a+b*(c-1))/2)*c;
writeln(k);
end.
Отвечает Барышникова Лера.
Program SAP;
var
S, d: integer;
i, N: byte;
a: array[1..255] of integer;
begin
write('Введите первый член арифметической прогрессии: ');
readln(a[1]);
write('Введите разность арифметической прогрессии: ');
readln(d);
write('Введите количество членов арифметической прогрессии: ');
readln(N);
for i:= 2 to N do begin
a[i]:= a[1] + (i - 1) * d;
S:= S + a[i]
end;
writeln('Сумма членов арифметической прогрессии: ', S);
end.
var
S, d: integer;
i, N: byte;
a: array[1..255] of integer;
begin
write('Введите первый член арифметической прогрессии: ');
readln(a[1]);
write('Введите разность арифметической прогрессии: ');
readln(d);
write('Введите количество членов арифметической прогрессии: ');
readln(N);
for i:= 2 to N do begin
a[i]:= a[1] + (i - 1) * d;
S:= S + a[i]
end;
writeln('Сумма членов арифметической прогрессии: ', S);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
