
Вопрос задан 02.04.2019 в 11:57.
Предмет Информатика.
Спрашивает Игнатов Владимир.
Помогите пожалуйста, нужно составить программу обработки данной строки, позволяющую выписать все
знаки сравнения и все скобки, сохранив их последовательность

Ответы на вопрос

Отвечает Суиндиккызы Радмира.
Теперь уже PascalABC.Net 3.2
var s:string;
i:integer;
begin
readln(s);
for i:=1 to s.Length do begin
if ((s[i]=')') or (s[i]='(') or (s[i]='>') or (s[i]='<') or (s[i]='=')) then write(s[i]);
end;
end.
Я надеюсь, <>=() - это все знаки, которые вы перечислили?
var s:string;
i:integer;
begin
readln(s);
for i:=1 to s.Length do begin
if ((s[i]=')') or (s[i]='(') or (s[i]='>') or (s[i]='<') or (s[i]='=')) then write(s[i]);
end;
end.
Я надеюсь, <>=() - это все знаки, которые вы перечислили?



Отвечает Gudimov Anton.
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
ReadlnString('Введите строку:').MatchValues('[()=<>]').Println('')
end.
Пример
Введите строку: Пусть F(x)=3a/x+(x-1)>5x/(2-x), тогда ...
()=()>()
// Внимание! Если программа не работает, обновите версию!
begin
ReadlnString('Введите строку:').MatchValues('[()=<>]').Println('')
end.
Пример
Введите строку: Пусть F(x)=3a/x+(x-1)>5x/(2-x), тогда ...
()=()>()


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili