Вопрос задан 01.04.2019 в 17:58.
Предмет Информатика.
Спрашивает Суминова Маша.
Написать программу, которая выводит на экран из введенной пользователем строки слово с заданным
пользователем номером C++ Пожалуйста, помогитеОтветы на вопрос
Отвечает Малышева Анастасия.
#include <bits/stdc++.h>
using namespace std;
int main(){ string s; getline(cin, s); int n; cin >> n; int cur = 1, i; for(i = 0 ; i < s.size() ; i ++) { if(s[i] == ' ') cur++; if(cur >= n) break; } string ans = ""; if(n != 1) ++i; while(s[i] != ' ' && i < s.size()) { ans += s[i]; ++i; } cout << ans << "\n";}
using namespace std;
int main(){ string s; getline(cin, s); int n; cin >> n; int cur = 1, i; for(i = 0 ; i < s.size() ; i ++) { if(s[i] == ' ') cur++; if(cur >= n) break; } string ans = ""; if(n != 1) ++i; while(s[i] != ' ' && i < s.size()) { ans += s[i]; ++i; } cout << ans << "\n";}
Топ вопросов за вчера в категории Информатика
Информатика 23
Информатика 38
Информатика 20
Информатика 14
Информатика 19
Информатика 21
Информатика 28
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
