Вопрос задан 01.04.2019 в 10:03.
Предмет Информатика.
Спрашивает Айтжанов Адилет.
Помогите составить программу, которая посчитает сумму натуральных чисел из промежутка от 1 до 100,
которые делятся на 17 и сумма цифр, которых не превышает 7. В Паскале.Ответы на вопрос
Отвечает Болонева Елена.
{сумма натуральных чисел из промежутка от 1 до 100,
которые делятся на 17 и сумма цифр, которых не
превышает 7. Можно перебором}
var i,s:integer;
begin
s:=0;
for i:=1 to 100 do
if (i mod 17=0) and (i div 10 + i mod 10<7) then
s:=s+i;
writeln(s);
end.
{результат 51}
{
Можно оптимизировать
в цикле изменив for i:=1 to 100 do
на
for i:=17 to 100 do}
{2 вариантө оптимальнее - перебираем только числа кратные 17]
var i,s:integer;
begin
s:=0; i:=17;
while i<=100 do
begin
if (i div 10 + i mod 10<7) then
s:=s+i;
i:=i+17;
end;
writeln(s);
end.
которые делятся на 17 и сумма цифр, которых не
превышает 7. Можно перебором}
var i,s:integer;
begin
s:=0;
for i:=1 to 100 do
if (i mod 17=0) and (i div 10 + i mod 10<7) then
s:=s+i;
writeln(s);
end.
{результат 51}
{
Можно оптимизировать
в цикле изменив for i:=1 to 100 do
на
for i:=17 to 100 do}
{2 вариантө оптимальнее - перебираем только числа кратные 17]
var i,s:integer;
begin
s:=0; i:=17;
while i<=100 do
begin
if (i div 10 + i mod 10<7) then
s:=s+i;
i:=i+17;
end;
writeln(s);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 21
Информатика 267
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
