Вопрос задан 07.05.2018 в 12:38.
Предмет Информатика.
Спрашивает Зобнин Игорь.
Напишите программу пожалуйста Ввести одномерный массив A из 13 элементов. Определить в нём среднее
арифметическое тех элементов, которые при делении на 4 дают остаток 1 или 3.Ответы на вопрос
Отвечает Дегтярева Оля.
Begin
S:=0;
n:=0;
for i:=1 to 13 do begin
readln (A[i]); end;
for i:=1 to 13 do begin
if (A[i] mod 4 = 1) or (A[i] mod 4 = 3) then begin S:=S+A[i]; n:=n+1; end;
end;
writeln (S/n);
end.
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
