Вопрос задан 30.03.2019 в 08:27.
Предмет Информатика.
Спрашивает Макшаков Антон.
Написать программу (в паскаль) по закупке товаров в магазине на определённую сумму денег, не
превышающую заданное количество денег.ВХОДНЫЕ ДАННЫЕ: С клавиатуры вводится сумма, на которую предполагается произвести покупки. Затем вводятся цена и количество товара №1, товара №2 и т.д. до тех пор пока не будет исчерпана сумма денег.Ответы на вопрос
Отвечает Левчук Женя.
Uses crt;
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itog<sum) do
begin
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.
var
sum,x,itog: real;
i,y: integer;
begin
i:=1;
itog:=0;
write ('Start summa: ');
readln (sum);
while (itog<sum) do
begin
write ('¹',i,': ');
i:=i+1;
readln (x);
write ('Kol-vo: ');
readln (y);
itog:=itog+y*x;
end;
if (itog>sum) then
writeln ('Itog: ',itog-y*x)
else
writeln ('Itog: ',itog);
end.
Отвечает Шапель Милана.
Uses crt;
var s:integer;
b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
s:=s+1;
write('Товар №',s,': ');
read(b);
write('Введите количество: ');
read(y);
a:=a-(b*y);
end;
end.
var s:integer;
b,y,a:real;
begin
write('Введите сумму денег, на которую собираетесь произвести покупки: ');
read(a);
while a>0 do begin
s:=s+1;
write('Товар №',s,': ');
read(b);
write('Введите количество: ');
read(y);
a:=a-(b*y);
end;
end.
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
