Вопрос задан 29.03.2019 в 02:59. Предмет Информатика. Спрашивает Шилова Варя.

Срооооочно пожалуйста Напишите программу на с++, которая вводит натуральное число N и выводит на

экран все натуральные числы, не превосходящие N и делящуеся на каждую из своих цифр
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сембай Мейрамбек.
#include <bits/stdc++.h>

using namespace std;

int main()
{
   int n; cin >> n;
   for (int i = 1; i <= n; ++i)
   {
       int tmp = i;
       bool fl = true;
       while (tmp) {
            int x = tmp % 10;
             if (x != 0)
                if (i % x != 0)
                  fl = false;
              if (!x) fl = false;
            tmp /= 10;
       }
       if (fl) cout << i << ' ';
   }
}


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос