Вопрос задан 27.03.2019 в 22:24.
Предмет Информатика.
Спрашивает Кириенко Михаил.
Паскаль Помогите доделать задачу Вклад в банке составляет x рублей. Ежегодно он увеличивается на p
процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей. Входные данные Программа получает на вход три натуральных числа: x, p, y. Выходные данные Программа должна вывести одно целое число. program u1; var x, p ,s,n: integer; y:real; begin read(x); read(p); read(y); s:=0; s:= x +(x*p)div 100; n:= 1; while (s < y) do begin s := s +((s*p)div 100); n:= n + 1; end; writeln (n); readln; end. Здесь где-то есть недоработка.Ответы на вопрос
Отвечает Barbq-Junior Андрюха.
Program u1;
var
x, p ,y, s, n: integer;
begin
readln(x,p,y);
s:=x;
n:= 0;
while (s < y) do
begin
s := s+trunc((s*p)/100);
n:= n+1;
end;
writeln(n);
end.
Пример:
100 10 500
18
var
x, p ,y, s, n: integer;
begin
readln(x,p,y);
s:=x;
n:= 0;
while (s < y) do
begin
s := s+trunc((s*p)/100);
n:= n+1;
end;
writeln(n);
end.
Пример:
100 10 500
18
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
