Вопрос задан 27.03.2019 в 12:55. Предмет Информатика. Спрашивает Смирнов Евгений.

Написать программу, которая сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число

вводится с клавиатуры). Использовать двоичный поиск.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Синковец Полина.
uses crt;
var a, b, c, n, i, j :integer;   
s :array [1..10000] of integer;
begin
   clrscr;
   writeln ('Vvedite razmer masiva');
   read (n);
   writeln  ('Vvedite chislo X');
   read (a);
   for i:=1 to n do 
   begin 
      writeln ('Vvedit s[', i, '] element'); 
      read (s[i]); 
   end;
   for i:=1 to n do 
      for j:=1 to n-1 do 
         if s[j]<s[j+1] then   
         begin   
            b:=s[j];   
            s[j]:=s[j+1];   
            s[j+1]:=b;   
         end;
   for i:=1 to n do 
   begin 
      write (s[i], ' '); 
      if s[i]=a then inc (c); 
   end;
writeln;
if c>0 then writeln ('3adanoe chislo prisytstvyet') else writeln('3adanoe chislo otsytstvyet');
end.

P.S. Надеюсь на благодарность и лучший ответ.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос