Вопрос задан 26.03.2019 в 04:45.
Предмет Информатика.
Спрашивает Стовба Данил.
Составить программу.Через двумерный массив. Дана матрица А.Сформировать вектор В,каждый элемент
которого равен длине соответствующей строке матрицы А. Длина строки считается по b1=√a11²+a12²+a13²+.. b2=√a21²+a22²+a23²+.. Матрица вводится с клавиатуры.(pascal)Ответы на вопрос
        Отвечает Побережник Марія.
                
    // PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество строк в матрице:');
var m:=ReadInteger('Количество столбцов в матрице:');
Writeln('Вводите элементы матрицы построчно');
var a:=new real[n,m];
var b:=new real[n];
for var i:=0 to n-1 do begin
b[i]:=0;
for var j:=0 to m-1 do begin
Read(a[i,j]);
b[i]+=Sqr(a[i,j])
end;
b[i]:=Sqrt(b[i])
end;
Writeln('Сформированный вектор');
b.Println;
end.
Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 3
Вводите элементы матрицы построчно
3.4 5.1 8
-1 0 1
-5.34 1.777 5
3 4 5
Сформированный вектор
10.0781942827076 1.4142135623731 7.52816903370268 7.07106781186548
                                        // Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество строк в матрице:');
var m:=ReadInteger('Количество столбцов в матрице:');
Writeln('Вводите элементы матрицы построчно');
var a:=new real[n,m];
var b:=new real[n];
for var i:=0 to n-1 do begin
b[i]:=0;
for var j:=0 to m-1 do begin
Read(a[i,j]);
b[i]+=Sqr(a[i,j])
end;
b[i]:=Sqrt(b[i])
end;
Writeln('Сформированный вектор');
b.Println;
end.
Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 3
Вводите элементы матрицы построчно
3.4 5.1 8
-1 0 1
-5.34 1.777 5
3 4 5
Сформированный вектор
10.0781942827076 1.4142135623731 7.52816903370268 7.07106781186548
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			