
Вопрос задан 24.03.2019 в 16:05.
Предмет Информатика.
Спрашивает Паскевич Кристина.
1)Составьте программу вычисления произведения S=1*2+3*4+5*6+...+101*102 (в паскале) 2)составьте
программу вычисления суммы S=0.5+1.5+2.5+... +98.5+99.5

Ответы на вопрос

Отвечает Асадулова Диана.
1)
var
com,i:integer;
begin
for i:= 1 to 101 do
if i mod 2 = 1 then
com:= com + i * i+1;
Writeln(com);
end.
Результат:
176902
2)
var
sum, x:Real;
begin
while x < 100 do begin
sum := sum + x;
x:= x+ 0.5
end;
Writeln(sum);
end.
Результат:
9950
var
com,i:integer;
begin
for i:= 1 to 101 do
if i mod 2 = 1 then
com:= com + i * i+1;
Writeln(com);
end.
Результат:
176902
2)
var
sum, x:Real;
begin
while x < 100 do begin
sum := sum + x;
x:= x+ 0.5
end;
Writeln(sum);
end.
Результат:
9950


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili