Вопрос задан 24.03.2019 в 15:17.
Предмет Информатика.
Спрашивает Кострикова Вика.
Составить алгоритм и написать программу на языке Pascal: Алгоритм вычисления значения функции F(n),
где n - натуральное число, задан следующими соотношениями: F(n) = F(n-1)+ F(n/2), при n>1 и n кратно 2 F(n)=f(n-1) + F(n-2) , при n >1 и n не кратно 2 F(1)=1 Чему равно значение функции F(8)?Ответы на вопрос
Отвечает Антошин Дмитрий.
function F(n:integer):integer;
begin
if n=1 then F:=1
else
if (n mod 2)=0 then F:=F(n-1)+F(n div 2)
else F:=F(n-1)+F(n-2)
end;
begin
Writeln('F(8)=',F(8))
end.
Результат выполнения программы:
F(8)=24
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
