
Вопрос задан 22.03.2019 в 18:14.
Предмет Информатика.
Спрашивает Balan Sergei.
Помогите написать программу, которая определяет, кратное ли число четырём. На Pascal ABC и C++
Пример: Ввод Вывод 32 Кратно 4 19 Не кратно 4

Ответы на вопрос

Отвечает Иванова Евгения.
// Программа будет выполняться до тех пор,
// пока не будет введено "0"
var
a : integer;
begin
a := 1;
while a <> 0 do begin
write('>> '); read(a);
if a mod 4 <> 0 then
write('не ');
writeln('кратно 4')
end
end.
// пока не будет введено "0"
var
a : integer;
begin
a := 1;
while a <> 0 do begin
write('>> '); read(a);
if a mod 4 <> 0 then
write('не ');
writeln('кратно 4')
end
end.



Отвечает Каретин Данил.
#include <iostream>
using spacename std;
void main(){
int a;
cin>> a;
if (a%4==0){
cout<<a<< "кратно 4";
}else{
cout<<a<<"не кратно 4";
}
}
progeram p1;
uses crt; var a:integer; begin
clrscr;read(a);
write (a);if a mod 4 = 0 then
write("кратно 4");
else write ("не кратно 4");
readkey;
end.
using spacename std;
void main(){
int a;
cin>> a;
if (a%4==0){
cout<<a<< "кратно 4";
}else{
cout<<a<<"не кратно 4";
}
}
progeram p1;
uses crt; var a:integer; begin
clrscr;read(a);
write (a);if a mod 4 = 0 then
write("кратно 4");
else write ("не кратно 4");
readkey;
end.


Топ вопросов за вчера в категории Информатика

Информатика 558

Информатика 33

Информатика 74

Информатика 12

Информатика 10

Информатика 33

Информатика 27
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili