Вопрос задан 05.05.2018 в 09:31.
Предмет Информатика.
Спрашивает Семёнова Дарья.
Составьте программу в pascal abc, которая заполняет массив а(1..10) случайными целыми числами в
диапазоне от 1 до 100 , затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученый массивыОтветы на вопрос
Отвечает Шестакова Ксения.
Var
a: array[1..10] of integer;
i, max, imax, min, imin: integer;
begin
Randomize;
max := 0;min := 101;
Write('Исходный массив: ');
for i := 1 to 10 do
begin
a[i] := random(100) + 1;
Write(a[i], ' ');
end;
Writeln();
For i:= 1 to 10 do begin
if a[i] > max then
begin
max := a[i];
imax := i;
end;
if a[i] < min then
begin
min := a[i];
imin := i;
end;
end;
swap(a[imax], a[imin]);
Write('Преобразованный массив: ');
For i:= 1 to 10 do
Write(a[i], ' ');
Writeln;
Write('Я поменял местами ', imax, ' и ', imin, ' элементы');
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
