Вопрос задан 20.03.2019 в 15:46.
Предмет Информатика.
Спрашивает Беляев Сергей.
Помогите написать программу по информатике по задаче! Пожалуйста! проверьте является ли
шестизначный номер билета счастливым (сумма первых трёх цифр ровна сумме последних трёх цифр) надо через поскали как то ((( НА ФОТО 3 ЗАДАЧА
Ответы на вопрос
Отвечает Muhangali Kuanish.
Var
x,a,b: integer;
begin
read(x);
a := x div 100000;
x := x mod 100000;
a := a + (x div 10000);
x := x mod 10000;
a := a + (x div 1000);
x := x mod 1000;
b := x div 100;
x := x mod 100;
b := b + (x div 10);
x := x mod 10;
b := b + x;
if a = b then
write('Билетик счастливый!')
else ('Билетик не счастливый');
end.
x,a,b: integer;
begin
read(x);
a := x div 100000;
x := x mod 100000;
a := a + (x div 10000);
x := x mod 10000;
a := a + (x div 1000);
x := x mod 1000;
b := x div 100;
x := x mod 100;
b := b + (x div 10);
x := x mod 10;
b := b + x;
if a = b then
write('Билетик счастливый!')
else ('Билетик не счастливый');
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
