
Вопрос задан 05.05.2018 в 07:22.
Предмет Информатика.
Спрашивает Пайвин Никита.
Напишите программу, подсчитывающую количество букв во введенной строке (слове).


Ответы на вопрос

Отвечает Варежкин Антон.
Var
s: string;
letters: set of 'А'..'я';
i, n: integer;
begin
writeln('Введите текст');
readln(s);
n := 0;
letters := ['А'..'я'];
for i := 1 to length(s) do
if s[i] in letters then n := n + 1;
writeln('Количество букв в строке: ', n);
end.
Тестовое решение:
Введите текст
Это текст содержащий буквы, цифры (1,2,3,4), латиницу werwer sxFFSFw и зн"ачки [email protected]#$%#^
Количество букв в строке: 43


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili