Вопрос задан 20.03.2019 в 01:22. Предмет Информатика. Спрашивает Безкурский Богдан.

ЭТО ЗАДАНИЕ НАДО РЕШИТЬ НА PYTHON "ГНЧЭ-1" – сложное электронное устройство, выдающее каждую

секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Входные данные Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Выходные данные Результат работы генератора Примеры Входные данные 2 Выходные данные 1 2 Входные данные 5 Выходные данные 1 2 2 3 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Хорошильцева Поля.
S = int(input('s = '))
t=1
k=1
while k<s:
  for i in range(t):
    print(t)
  t=t+1
  k=k+t
for i in range(k-t,s):
  print(t)

Пример:
s = 5
1
2
2
3
3
0 1
Отвечает Леонардыч Евгений.
 #!/usr/bin/env python
# encoding: utf-8
# (c) NaaMan

print "Генератор готов к работе"
s = int( input("Введите количество секунд: ") )
if 0 < s <= 1000000:
    t = 1
    r = 1
    for i in range(1, s + 1):
        print r,
        t += 1
        if t > r:
            r += 1
            t = 1
print "\nГенератор закончил работу"


0 1

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос