Вопрос задан 05.05.2018 в 00:30.
Предмет Информатика.
Спрашивает Ільчишин Настя.
Напишите программу в ПаскалеABC, выводящую n-ую цифру в последовательности натуральных чисел :
1234567891011... Вводится число n до 100 При решении этой задачи нельзя использовать любой из видов условной инструкции if. Вывести надо только ответОтветы на вопрос
Отвечает Барашева Яна.
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
var n:=ReadInteger('n=');
Writeln(1.To((n+10) div 2).JoinIntoString('')[n]);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
