Вопрос задан 04.05.2018 в 14:04.
Предмет Информатика.
Спрашивает Нехаенко Алексей.
Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный
элемент кратный 9.Ответы на вопрос
Отвечает Алиева Лейла.
Const
N = 30;
Var
A:array[1..N] of byte;
i,Max:integer;
Begin
Max:=0;
For i:= 1 to N do
Begin
A[i]:=random(101);
if (A[i] mod 9 = 0)and(A[i] > Max) then Max:=A[i];
Write(A[i],' ');
End;
WriteLn;
if Max = 0 then WriteLn('В массиве нет элементов, кратных 9')
else WriteLn('Max = ',Max)
End.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
