Вопрос задан 15.03.2019 в 17:51.
Предмет Информатика.
Спрашивает Котов Никита.
Напишите программу, которая по заданному натуральному n печатает первые n чисел последовательности
1, 2, 4, 8, 16, 32. В первой строке содержится n (1 ≤ n ≤ 50) – количество чисел. Вывести первые n чисел геометрической прогрессии со знаменателем 2 и первым членом 1. с++Ответы на вопрос
Отвечает Званкович Евгения.
#include <stdio.h>
int main()
{
int n, i;
scanf("%d", &n);
if (n>=1&&n<=50)
{
for (i=1; i<=n;i*=2){
printf("%d ", i); }
}
return 0;
}
int main()
{
int n, i;
scanf("%d", &n);
if (n>=1&&n<=50)
{
for (i=1; i<=n;i*=2){
printf("%d ", i); }
}
return 0;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
