Вопрос задан 14.03.2019 в 11:07.
Предмет Информатика.
Спрашивает Zhovcak Victor.
Написать программу с помощью операторы if. Оператор for применять не требуется. Ладья бьет либо
строго вертикально на любой клетке, либо строго горизонтально. В этом случае меняется у фигуры либо только координата X(номер строки), либо только координата Y(номер столбца). Требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке. Входные данные Вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. Координаты - целые числа в интервале от 1 до 8. Выходные данные Требуется вывести слово YES, если ладья сможет побить фигуру за 1 ход и NO - в противном случае. Примеры Входные данные 1 1 2 2 Выходные данные NO Входные данные 1 1 2 1 Выходные данные YES
Ответы на вопрос
Отвечает Карайсили Оленька.
Var
x1,y1,x2,y2:byte;
Begin
Read(x1,y1,x2,y2);
if (x1-x2 = 0)xor(y1-y2 = 0) then Write('YES')
else Write('NO')
End.
x1,y1,x2,y2:byte;
Begin
Read(x1,y1,x2,y2);
if (x1-x2 = 0)xor(y1-y2 = 0) then Write('YES')
else Write('NO')
End.
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
