Вопрос задан 12.03.2019 в 17:19.
Предмет Информатика.
Спрашивает Яковлева Яна.
Написать программу,которая выведет все числа кратные 3 в диапазоне от 26 до 87
Ответы на вопрос
Отвечает Казанцев Иван.
//Pascal ABC.NET v3.1 сборка 1172
begin
range(26,87).Where(x -> x mod 3=0).Println(',');
end.
begin
range(26,87).Where(x -> x mod 3=0).Println(',');
end.
Отвечает Матюшенко Екатерина.
Решение №1 (через целочисленное деление)
var a: integer;
begin
a:=26;
repeat
if a mod 3 =0 then write(a:3);
a:=a+1;
until a >87;
end.
Решение №2 (без целочисленного деления)
Заметим, что первое число в данном диапазоне кратное 3 равно 27. Тогда каждое следуещее число на 3 больше предыдущего:
var a: integer;
begin
a:=27;
repeat
write(a:3);
a:=a+3;
until a >87;
end.
var a: integer;
begin
a:=26;
repeat
if a mod 3 =0 then write(a:3);
a:=a+1;
until a >87;
end.
Решение №2 (без целочисленного деления)
Заметим, что первое число в данном диапазоне кратное 3 равно 27. Тогда каждое следуещее число на 3 больше предыдущего:
var a: integer;
begin
a:=27;
repeat
write(a:3);
a:=a+3;
until a >87;
end.
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
