Вопрос задан 09.03.2019 в 02:11.
Предмет Информатика.
Спрашивает Хужин Диёр.
Паскаль Составить программу, которая выводит меню и при нажатии вводе цифры вычисляет
соответствующее выражение: 1 - y= (a+b)^2 2 - y= a^2-b^2 3 - y= 1/(a+b)Ответы на вопрос
Отвечает Ковальчук Денис.
Var i,y,a,b: single;
begin
writeln('Выберите действие: 1)y=(a+b)^2; 2)y=a^2-b^2; 3)y=1/(a+b)');
read(i);
if i=1 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a+b)*(a+b));
end
else begin
if i=2 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a*a)-(b*b));
end
else begin
if i=3 then begin
writeln('Введите a и b');
read(a,b);
write('y=',1/(a+b));
end;
end;
end;
end.
begin
writeln('Выберите действие: 1)y=(a+b)^2; 2)y=a^2-b^2; 3)y=1/(a+b)');
read(i);
if i=1 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a+b)*(a+b));
end
else begin
if i=2 then begin
writeln('Введите a и b');
read(a,b);
write('y=',(a*a)-(b*b));
end
else begin
if i=3 then begin
writeln('Введите a и b');
read(a,b);
write('y=',1/(a+b));
end;
end;
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
