
Вопрос задан 05.03.2019 в 16:54.
Предмет Информатика.
Спрашивает Чернова Александра.
Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить,
существует ли треугольник с длинами сторон x,y,z. Если треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Ответы на вопрос

Отвечает Башинський Денис.
var x,y,z:real;
begin
readln(x,y,z);
if (x<y+z) and (y<x+z) and (z<x+y) then begin
if (x=y) and (y=z) then writeln('Ravnostoronnii') else writeln('Ne ravnostoronnii');
end else writeln('Ne vozmojno sostavit');
end.
var a:array[1..10]of integer;
i,sum:integer;
begin
for i:=1 to 10 do readln(a[i]);
for i:=1 to 9 do begin
if (a[i]>0) and (a[i+1]<0) then sum:=sum+1;
if (a[i]<0) and (a[i+1]>0) then sum:=sum+1;
end;
writeln(sum);
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili