Вопрос задан 01.03.2019 в 22:25.
Предмет Информатика.
Спрашивает Кёлер Лера.
Помогите составить программу в С++: Создать функцию square (x) нахождение его площади квадрата и
функцию maxi (x, y) нахождение наибольшего из двух значений. Дано сторону квадрата. Составить программу с использованием функции square и maxi, которая для двух квадратов, будет находить тот, площадь которого больше и выводить значение большей площади на экран.Ответы на вопрос
Отвечает Макаров' Александр.
#include <iostream>
using namespace std;
double square(double x) {
return x*x;
}
double maxi(double x, double y) {
if (x>y)
return x;
else
return y;
}
int main() {
double a1,a2,s1,s2;
cin >> a1 >> a2;
cout << "s=" << maxi(square(a1),square(a2)) << endl;
return 0;
}
using namespace std;
double square(double x) {
return x*x;
}
double maxi(double x, double y) {
if (x>y)
return x;
else
return y;
}
int main() {
double a1,a2,s1,s2;
cin >> a1 >> a2;
cout << "s=" << maxi(square(a1),square(a2)) << endl;
return 0;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
