Вопрос задан 01.05.2018 в 12:40.
Предмет Информатика.
Спрашивает Борозна Настя.
1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся
на цифру 5 или 2Ответы на вопрос
Отвечает Бужак Лиза.
Program z9; Var a,del,del_2,i,j:integer; b,b_2: string;Begin write('Введите число - '); readln(a); del:= 5; del_2:= 2; i:= 0; j:= 0; while (a >= del) do begin if (a mod del = 0) then begin b:= b + del + ' '; i:= i + 1; end; del:= del + 10; end; while (a >= del_2) do begin if (a mod del_2 = 0) then begin b_2:= b_2 + del_2 + ' '; j:= j + 1; end; del_2:= del_2 + 2; end; writeln('Кол-во делителей заканчивающихся на 5 - ', i); writeln(b); writeln; writeln('Кол-во делителей заканчивающихся на 2 - ', j); writeln(b_2); writeln;End.

Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
