Информатика.Паскаль.Дано натуральное число N. Составить программу, которая определяет, сколько цифр
этого числа кратны трем. P.S т.е мало того что нам нужно определить кратность каждой цифры этого числа ина выходе получит сколько этих чисел.Ответы на вопрос
var
N, count:integer;
begin
write('N = ');
readln(N);
count := 0;
while N > 0 do
begin
if (N mod 10) mod 3 = 0 then
count := count + 1;
N := N div 10;
end;
writeln('Count = ', count);
readln;
end.
Для решения данной задачи на языке программирования Паскаль можно использовать следующий алгоритм:
1. Объявить переменные: - N (натуральное число, вводимое пользователем) - digitCount (количество цифр числа N) - i (счетчик цикла) - currentDigit (текущая цифра числа N) - count (счетчик кратных трём цифр)
2. Ввести значение переменной N с клавиатуры.
3. Инициализировать переменные digitCount и count значением 0.
4. Вычислить количество цифр числа N: - Присвоить переменной i значение 0. - Пока N > 0, выполнять следующие действия: - Присвоить переменной currentDigit значение N mod 10 (остаток от деления N на 10). - Увеличить переменную digitCount на 1. - Присвоить переменной N значение N div 10 (целая часть от деления N на 10).
5. Присвоить переменной N исходное значение, введенное пользователем.
6. Пока i < digitCount, выполнять следующие действия: - Присвоить переменной currentDigit значение N mod 10. - Если currentDigit кратно трём (currentDigit mod 3 = 0), увеличить переменную count на 1. - Присвоить переменной N значение N div 10. - Увеличить переменную i на 1.
7. Вывести значение переменной count - количество цифр числа N, кратных трём.
Пример программы на языке Паскаль:
```pascal program CountDigitsDivisibleByThree; var N, digitCount, i, currentDigit, count: integer; begin writeln('Введите натуральное число N:'); readln(N); digitCount := 0; count := 0; i := 0; while N > 0 do begin currentDigit := N mod 10; digitCount := digitCount + 1; N := N div 10; end; N := N; i := 0; while i < digitCount do begin currentDigit := N mod 10; if currentDigit mod 3 = 0 then count := count + 1; N := N div 10; i := i + 1; end; writeln('Количество цифр числа N, кратных трём: ', count); end. ```
После запуска программы пользователю будет предложено ввести натуральное число N. Затем программа вычислит количество цифр числа N, кратных трём, и выведет результат на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
