Задачи для зачета по Турбо Паскалю! Очень важно!1) Даны число A>0, числа x1,x2....Необходимо
вводить числа x1,x2.... , пока сумма модулей введенных чисел буде меньше A. Определить число введенных чисел.2)Даны число n и векторы а=(а1,а2,....,аn) , b=(b1,b2,...,bn)Найти координаты вектора с, равного сумме векторов a и b, если a1<b1, в противном случае равного разности векторов a и b. На экран выводить информацию о том, как получен вектор c.3) Составить программу, которая данное слово запишет в обратном порядке.Заранее спасибо!Ответы на вопрос
var s:string;
begin;
for i:=length(s) downto 1 do
write(s[i]);
end.
Problem 1: Finding the Number of Entered Numbers
To solve this problem, we need to input numbers x1, x2, ..., until the sum of their absolute values is less than A. We then need to determine the number of entered numbers.
Here's a possible solution in Turbo Pascal:
```pascal program Problem1; var A, sum: real; count: integer; x: real; begin writeln('Enter the value of A:'); readln(A); sum := 0; count := 0; repeat writeln('Enter a number:'); readln(x); sum := sum + abs(x); count := count + 1; until sum >= A; writeln('The number of entered numbers is: ', count); end. ```
In this program, we use a `repeat...until` loop to continuously prompt the user to enter numbers until the sum of their absolute values is greater than or equal to A. We keep track of the sum and the count of entered numbers using the variables `sum` and `count`, respectively.
After the loop terminates, we output the value of `count`, which represents the number of entered numbers.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
