Напишите программу, которая найдет значение выражения 1*1+2*2...n*n. В паскале.
Ответы на вопрос
var i,n,s:integer;
begin
readln(n);
s:=0;
for i:=1 to n do
s:=s+i*i;
writeln('s=',s);
end.
Конечно, вот пример программы на языке Pascal, которая вычисляет значение выражения \(1^2 + 2^2 + \ldots + n^2\):
```pascal program SumOfSquares;
var n, sum, i: integer;
begin // Вводим значение n write('Введите значение n: '); readln(n);
// Инициализируем сумму sum := 0;
// Вычисляем сумму квадратов от 1 до n for i := 1 to n do begin sum := sum + i * i; end;
// Выводим результат writeln('Сумма квадратов от 1 до ', n, ' равна ', sum);
// Ждем нажатия клавиши перед выходом readln; end. ```
В этой программе мы используем цикл `for`, чтобы пройти через все значения от 1 до n и добавить квадрат каждого числа к общей сумме. После этого программа выводит результат на экран.
Обратите внимание, что Pascal - устаревший язык программирования, и в современных условиях рекомендуется использовать более современные языки, такие как Python, Java, C++, и так далее.
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
