Вопрос задан 28.02.2019 в 13:04. Предмет Информатика. Спрашивает Галактионов Илья.

Все сделать в Паскале. Дан массив из 12 элементов, в котором есть положительные и отрицательные чи

сла (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. Составьте программу, в которой 1 вариант: Все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. Вывести на экран исходный и полученный массив как в классе; Дополнительная оценка, если появляется дополнительная возможность ввода своих чисел с клавиатуры с клавиатуры.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Науменков Миша.
Program mm;
var a:array[1..12] of integer;
begin
for i:=1 to 12 do begin
а[1]:=5;
 а[2]:=4;
 а[3]:=-3;
 а[4]:=1;
 а[5]:=0;
а[6]:=-4;
 а[7]:=(у тебя не написано);
 а[8]=25;
 а[9]=-8;
 a[10]=-5;
 а[11]=-17;
 а[12]=-1;
end;
writeln('Вот исходный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]); 
for i:=1 to 12 do begin
if (A[i]<0) then a[i]:=1;
if (a[i]>0) then a[i]:=-5;
end;
writeln('Вот полученный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]); 
writeln(' Введите 12 чисел');
for i:=1 to 12 do readln(A[i]);          (это доп оценка)
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Ниже приведен код программы на языке Паскаль, который реализует указанную задачу:

program ChangeArrayElements; const n = 12; var arr: array[1..n] of integer; i: integer;

procedure PrintArray(); begin for i := 1 to n do write(arr[i], ' '); writeln; end;

begin // Исходный массив arr[1] := 5; arr[2] := 4; arr[3] := -3; arr[4] := 1; arr[5] := 0; arr[6] := -4; arr[7] := 0; arr[8] := 25; arr[9] := -8; arr[10] := -5; arr[11] := -17; arr[12] := -1;

writeln('Исходный массив:'); PrintArray();

// Замена элементов массива for i := 1 to n do begin if arr[i] < 0 then arr[i] := 1 else if arr[i] > 0 then arr[i] := -5; end;

writeln('Полученный массив:'); PrintArray();

readln; end.

В данной программе исходный массив задан напрямую, но вы можете добавить возможность ввода с клавиатуры, используя операторы readln и writeln.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос