Помогите срочно надо!!! 1.Дан двумерный массив.Определить: а) Сумму всех элементов третьей строки
массива; б) Сумму всех элементов 5-го столбца массива. 2.Дан двумерный массив.Определить: а) Сумму отрицательных элементов пятой строки массива; б) Сумму элементов четвертого столбца массива, меньших 100; в) количество элементов четвертой строки массива, меньших 5; г) количество ненулевых элементов второго столбца массива, больших 15. Нужно написать программы в Паскале.Заранее спасибо.Ответы на вопрос
//1)
var
A: array[1..5, 1..8] of integer;
i, j: byte;
sumR, sumC: integer;
begin
randomize;
writeln('Исходный массив':28);
for i := 1 to 5 do
begin
for j := 1 to 8 do
begin
A[i, j] := random(61)-30;
write(A[i,j]:5);
if i = 3 then sumR := sumR + A[i, j];
if j = 5 then sumC := sumC + A[i, j];
end;
writeln;
end;
writeln('Сумма элементов 5 столбца = ', sumC);
writeln('Сумма элементов 3 строки = ', sumR);
end.
//2)
var
A: array[1..5, 1..8] of integer;
i, j: byte;
sumA, sumB, countV, countG: integer;
begin
randomize;
writeln('Исходный массив':28);
for i := 1 to 5 do
begin
for j := 1 to 8 do
begin
A[i, j] := random(300)-150;
write(A[i,j]:5);
if ((i = 5) and (A[i, j] < 0)) then sumA := sumA + A[i, j];
if ((j = 4) and (A[i, j] < 100)) then sumB := sumB + A[i, j];
if ((i = 4) and (A[i, j] < 5)) then countV := countV + 1;
if ((j = 2) and (A[i, j] > 15)) then countG := countG + 1;
end;
writeln;
end;
writeln('Сумма отрицательных 5 строки = ', sumA);
writeln('Сумма меньших 100 4-ого столбца = ', sumB);
writeln('Количество меньших 5 4-ой строки = ', countV);
writeln('Количество ненулевых, больших 15 2-ого столбца = ', countG);
end.
Для решения задачи с двумерным массивом и определения суммы элементов третьей строки и пятого столбца, а также для определения суммы отрицательных элементов пятой строки, суммы элементов четвертого столбца, меньших 100, количества элементов четвертой строки, меньших 5, и количества ненулевых элементов второго столбца, больших 15, вам потребуется написать программу на языке Паскаль.
Решение задачи 1:
1. Создайте двумерный массив, содержащий нужные вам элементы. 2. Используйте цикл для вычисления суммы элементов третьей строки массива. 3. Используйте цикл для вычисления суммы элементов пятого столбца массива. 4. Выведите полученные результаты.Решение задачи 2:
1. Создайте двумерный массив, содержащий нужные вам элементы. 2. Используйте цикл для вычисления суммы отрицательных элементов пятой строки массива. 3. Используйте цикл для вычисления суммы элементов четвертого столбца массива, меньших 100. 4. Используйте цикл для подсчета количества элементов четвертой строки массива, меньших 5. 5. Используйте цикл для подсчета количества ненулевых элементов второго столбца массива, больших 15. 6. Выведите полученные результаты.Пример программы на языке Паскаль для решения задачи 1:
```pascal program ArraySum; const N = 5; // размер массива var arr: array[1..N, 1..N] of integer; // двумерный массив sumThirdRow, sumFifthColumn: integer; // переменные для хранения суммы i, j: integer; // переменные для циклов begin // Заполнение массива (пример) arr[1, 1] := 1; arr[1, 2] := 2; // ... // Вычисление суммы элементов третьей строки sumThirdRow := 0; for j := 1 to N do begin sumThirdRow := sumThirdRow + arr[3, j]; end; // Вычисление суммы элементов пятого столбца sumFifthColumn := 0; for i := 1 to N do begin sumFifthColumn := sumFifthColumn + arr[i, 5]; end; // Вывод результатов writeln('Сумма элементов третьей строки: ', sumThirdRow); writeln('Сумма элементов пятого столбца: ', sumFifthColumn); end. ```
Пример программы на языке Паскаль для решения задачи 2:
```pascal program ArraySum; const N = 5; // размер массива var arr: array[1..N, 1..N] of integer; // двумерный массив sumNegFifthRow, sumLess100FourthColumn: integer; // переменные для хранения суммы countLess5FourthRow, countNonZeroSecondColumn: integer; // переменные для подсчета i, j: integer; // переменные для циклов begin // Заполнение массива (пример) arr[1, 1] := 1; arr[1, 2] := -2; // ... // Вычисление суммы отрицательных элементов пятой строки sumNegFifthRow := 0; for j := 1 to N do begin if arr[5, j] < 0 then sumNegFifthRow := sumNegFifthRow + arr[5, j]; end; // Вычисление суммы элементов четвертого столбца, меньших 100 sumLess100FourthColumn := 0; for i := 1 to N do begin if arr[i, 4] < 100 then sumLess100FourthColumn := sumLess100FourthColumn + arr[i, 4]; end; // Подсчет количества элементов четвертой строки, меньших 5 countLess5FourthRow := 0; for j := 1 to N do begin if arr[4, j] < 5 then countLess5FourthRow := countLess5FourthRow + 1; end; // Подсчет количества ненулевых элементов второго столбца, больших 15 countNonZeroSecondColumn := 0; for i := 1 to N do begin if (arr[i, 2] <> 0) and (arr[i, 2] > 15) then countNonZeroSecondColumn := countNonZeroSecondColumn + 1; end; // Вывод результатов writeln('Сумма отрицательных элементов пятой строки: ', sumNegFifthRow); writeln('Сумма элементов четвертого столбца, меньших 100: ', sumLess100FourthColumn); writeln('Количество элементов четвертой строки, меньших 5: ', countLess5FourthRow); writeln('Количество ненулевых элементов второго столбца, больших 15: ', countNonZeroSecondColumn); end. ```
Надеюсь, это поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их.
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
