Помогите решить 1) дан целочисленный массив, вывести на экран упорядоченный массив от наибольшего
до наименьшего.Ответы на вопрос
// Внимание! Если программа не работает, обновите её версию!
begin
var a:=ArrRandom(Readinteger('n='),1,99); a.Println;
a.SortedDescending.Println
end.
Пример
n= 15
56 5 67 93 77 58 10 48 29 13 87 51 16 55 88
93 88 87 77 67 58 56 55 51 48 29 16 13 10 5
#include <iostream>
using namespace std;
int main(){ int n; cin >> n; int* arr = new int[n]; for (size_t i = 0; i < n; i++) { cin >> arr[i]; }
for (int i = 0; i < n - 1; i++) { bool swapped = false; for (int j = 0; j < n - i - 1; j++) { if (arr[j] < arr[j + 1]) { swap(arr[j], arr[j + 1]); swapped = true; } } if (!swapped) break; }
for (size_t i = 0; i < n; i++) { cout << arr[i] << " "; } cout << endl; return 0;}
Конечно, я могу помочь вам написать программу на одном из популярных языков программирования. Давайте рассмотрим пример на языке Python. Вам нужно ввести массив, а затем программа выведет его в порядке убывания.
```python # Ввод массива с клавиатуры array = list(map(int, input("Введите целочисленный массив, разделяя элементы пробелами: ").split()))
# Сортировка массива в порядке убывания sorted_array = sorted(array, reverse=True)
# Вывод отсортированного массива print("Отсортированный массив от наибольшего до наименьшего:", sorted_array) ```
Пример использования: ``` Введите целочисленный массив, разделяя элементы пробелами: 5 2 8 1 7 Отсортированный массив от наибольшего до наименьшего: [8, 7, 5, 2, 1] ```
Вы можете использовать аналогичный подход и на других языках программирования, таких как Java, C++, JavaScript и т.д. Принцип сортировки массива с использованием встроенных функций или алгоритмов сортировки остается примерно тем же.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
