Составить программу на языке паскаль. Составить блок схему. Дан массив вещественных чисел. Ко всем
отрицательным элементам прибавить элемент с номером , к остальным - элемент с номером .Ответы на вопрос
m=10;
var
i,s,n,m1,m2:integer;
a:array[1..m]of integer;
begin
write('Исходный массив: ');
for i:=1 to m do
begin
a[i]:=random(-5,10);
write(a[i],' ');
end;
writeln;
repeat
write('Введите m1 и m2: ');
readln(m1,m2);
until (m1>0) and (m2>0) and (m1<=m) and (m2<=m);
n:=a[m1];
s:=a[m2];
write('Измененный массив: ');
for i:=1 to m do
begin
if a[i]<0 then a[i]:=a[i]+n
else a[i]:=a[i]+s;
write(a[i],' ');
end;
end.
Программа на языке Паскаль для выполнения данной задачи может выглядеть следующим образом:
```pascal program ArrayManipulation;
const N = 10; // размер массива
var arr: array[1..N] of real; // объявление массива i: integer; // переменная для цикла
begin // заполнение массива случайными вещественными числами for i := 1 to N do arr[i] := Random; // используем генератор случайных чисел
// вывод исходного массива writeln('Исходный массив:'); for i := 1 to N do write(arr[i]:0:2, ' '); writeln;
// обработка массива for i := 1 to N do begin if arr[i] < 0 then arr[i] := arr[i] + arr[i mod N + 1] // прибавляем элемент с номером (i mod N + 1) else arr[i] := arr[i] - arr[i mod N + 1]; // вычитаем элемент с номером (i mod N + 1) end;
// вывод измененного массива writeln('Измененный массив:'); for i := 1 to N do write(arr[i]:0:2, ' '); writeln; end. ```
Блок-схема для данной программы может выглядеть следующим образом:
``` ┌───────────────┐ │ Начало │ ├───────────────┤ │ Заполнение │ │ массива │ ├───────────────┤ │ Вывод │ │ исходного │ │ массива │ ├───────────────┤ │ Обработка │ │ массива │ ├───────────────┤ │ Вывод │ │ измененного │ │ массива │ └───────────────┘ ```
В данной программе мы сначала заполняем массив случайными вещественными числами, затем выводим исходный массив. Далее проходим по всем элементам массива и прибавляем или вычитаем элемент с номером `(i mod N + 1)`, в зависимости от знака текущего элемента. Наконец, выводим измененный массив.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
