Написать программу которая 10 раз выводит на екран Имя и Фамилию. Это турбо паскаль - использование
цыклов while, for и других.пожалуйста очень надо!!))Ответы на вопрос
Ниже жирным шрифтом приведен код программы на Паскале. В фигурных скобках обычным шрифтом - комментарии. Можно их оставить - компилятор не сможет их прочитать и программа все равно будет работать.
program printname;
var first_name, family_name : string;
i : byte;
begin
write('Введи свое имя: ');
readln(first_name);{считываем имя в переменную first_name}
write('Введи свою фамилию: ');
readln(family_name); {считываем фамилию в переменную family_name}
for i := 1 to 10 do writeln(family_name, ' ', first_name);{В цикле for со счетчиком i изменяющимся от 1 до 10 печатаем строки с фамилией и именем через пробел}
end.
// Программа выводит по 10 раз имя и фамилию тремя разными циклами for while
// repeat until
Program LoopName;
Uses Crt;
var name,s_name:string;
i:integer;
begin
clrscr;
write('Введите имя: ');
readln(name);
write('Введите фамилию: ');
readln(s_name);
writeln('Цикл For');
for i:=1 to 10 do writeln(name,' ',s_name );
writeln;
writeln('Цикл while');
i:=1;
while (i<=10) do
begin
writeln(name,' ',s_name );
i:=i+1;
end;
writeln;
writeln('Цикл repeat until');
i:=0;
repeat
writeln(name,' ',s_name );
i:=i+1;
until(i=10);
readkey;
end.
Вот пример программы на Turbo Pascal, которая выводит имя и фамилию 10 раз:
```pascal program PrintName; var i: integer; firstName, lastName: string; begin firstName := 'Имя'; lastName := 'Фамилия'; for i := 1 to 10 do begin writeln(firstName, ' ', lastName); end; end. ```
В этой программе используется цикл `for`, который выполняется 10 раз. Внутри цикла происходит вывод на экран комбинации имени и фамилии. В данном случае, имя и фамилия заданы в коде программы как строки "Имя" и "Фамилия". Если вы хотите, чтобы пользователь вводил имя и фамилию, вы можете использовать функцию `readln` для чтения значений с клавиатуры.
Примечание: Программа написана на Turbo Pascal, который является устаревшим языком программирования. Если вы хотите использовать современный аналог Turbo Pascal, рекомендуется использовать среду разработки Lazarus, которая поддерживает синтаксис Turbo Pascal [[2]](http://mironchenko.com/__My_php_sources/Books/Mir07%20Imperativnoe%20i%20Objektno-orientirovannoe%20programmirovanie%20na%20TP%20i%20Delphi.pdf).
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
