Напишите программу, которая считывает, введенное пользователем целое число, определяет и выводит на
экран, является ли оно четным или нечетным. C тернарным операторомОтветы на вопрос
begin
write('n='); readln(n);
s:=n mod 2 = 0?'четное':'нечетное';
writeln(s);
end.
Пример:
n=20
четное
Конечно, вот пример программы на языке программирования Python, использующей тернарный оператор для определения четности числа:
```python # Считываем целое число от пользователя user_input = int(input("Введите целое число: "))
# Используем тернарный оператор для определения четности result = "Четное" if user_input % 2 == 0 else "Нечетное"
# Выводим результат на экран print(f"Введенное число {user_input} является {result}.") ```
Как это работает:
1. `input("Введите целое число: ")` - эта строка запрашивает у пользователя ввод целого числа. Функция `int()` используется для преобразования введенной строки в целое число.
2. `user_input % 2 == 0` - проверяет, является ли введенное число четным. Оператор `%` возвращает остаток от деления, поэтому если остаток от деления на 2 равен 0, то число четное.
3. `"Четное" if user_input % 2 == 0 else "Нечетное"` - это тернарный оператор. Если условие (число четное) истинно, то результатом будет строка "Четное", в противном случае - "Нечетное".
4. `print(f"Введенное число {user_input} является {result}.")` - выводит результат на экран, подставляя в строку значения переменных `user_input` и `result`.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
