В ПаскалеABC:1)Вывести на экран квадраты и кубы чисел от 2 до 102)Найти сумму целых положительных
четных чисел меньше 2003) Найти сумму целых положительных чисел, кратных 4 и меньше 100Хотя бы с одним помогите,пожалуйста, напишите программуОтветы на вопрос
в одной программе предусмотренны все 3 условия
program abc;
var i,sum1,sum2:integer;
begin
for i:=2 to 10 do
writeln('kvadraty',i*i,' Kyby',i*i*i);
for i:=1 to 200 do
sum1:=sum1+i;
writeln(sum1);
for i:=1 to 99 do
if i mod 4<>0 then sum2:=sum2+i;
writeln(sum2);
end.
Я могу помочь вам с написанием программ на языке PascalABC.NET. Вот примеры программ, которые решают ваши задачи:
1) Вывести на экран квадраты и кубы чисел от 2 до 10
```pascal begin for var i := 2 to 10 do Println($'{i}^2 = {i*i}, {i}^3 = {i*i*i}'); end. ```
2) Найти сумму целых положительных четных чисел меньше 200
```pascal begin var sum := 0; for var i := 2 to 198 step 2 do sum += i; Println($'Сумма = {sum}'); end. ```
3) Найти сумму целых положительных чисел, кратных 4 и меньше 100
```pascal begin var sum := 0; for var i := 4 to 96 step 4 do sum += i; Println($'Сумма = {sum}'); end. ```
Вы можете найти больше примеров программ на языке PascalABC.NET на сайте [Samples - PascalABC.NET](https://www.pascalabc.net/en/samples). Надеюсь, это вам поможет.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
