 
Пожалуйста помогите решить на паскаль с постусловием Дано натуральное число M. Написать программу
для вычисления первой цифры числа M. входные данные 54321 выходные данные 5. Дано натуральное число M. Написать программу для вычисления второй цифры числа М(M>10) входные данные 54321 выходные данные 4. 0
        0
         0
        0
    Ответы на вопрос
 
        m, i: integer;
a: array[1..10] of integer;
begin
readln(m);
i := 0;
repeat
i := i + 1;
a[i] := m mod 10;
m := m div 10;
until m = 0;
writeln('Первая цифра ', a[i]);
writeln('Вторая цифра ', a[i - 1]);
end.
 0
                    0
                     0
                    0
                 
            Конечно, вот пример программы на Pascal для решения вашей задачи:
```pascal program ExtractDigits;
var M, remainder: integer;
begin // Вводим натуральное число M write('Введите натуральное число M: '); readln(M);
// Вычисляем первую цифру числа M writeln('Первая цифра числа M: ', M div 10000);
// Вычисляем вторую цифру числа M (при условии M > 10) if M > 10 then begin remainder := M div 1000; // Получаем первые две цифры числа remainder := remainder mod 10; // Получаем вторую цифру writeln('Вторая цифра числа M: ', remainder); end else begin writeln('Число M меньше 10, вторая цифра не существует.'); end;
end. ```
Программа сначала запрашивает у пользователя ввод натурального числа M. Затем она вычисляет и выводит первую цифру числа M, а затем, при условии, что M больше 10, вычисляет и выводит вторую цифру числа M. Если M меньше 10, программа сообщает, что вторая цифра не существует.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			