
Pascal. Помогите решить.Дано двухзначное число. Написать программу для определения: кратна ли сумма
его цифр шести?

Ответы на вопрос

Begin
readln(b); {вводим 2-ух значное число}
a1:=b div 10;
a2:=b mod 10;
S:=a1+a2;
if s mod 6=0 then writeln('Кратно') else writeln('не кратно');
readln;
end.



Я могу помочь вам с решением задачи на Pascal. Для определения, кратна ли сумма цифр двухзначного числа шести, вам нужно выполнить следующие шаги:
- Получить цифры числа, разделив его на 10 и взяв остаток от деления. Например, если число 34, то цифры 3 и 4 можно получить так: 34 div 10 = 3, 34 mod 10 = 4. - Сложить цифры числа и проверить, делится ли сумма на 6 без остатка. Например, если сумма цифр 34 равна 7, то 7 mod 6 = 1, что означает, что сумма не кратна 6. - Вывести результат на экран в виде сообщения. Например, если число 36, то можно вывести "Сумма цифр числа 36 кратна 6". Если число 35, то можно вывести "Сумма цифр числа 35 не кратна 6".
Ниже приведен пример программы на Pascal, которая решает эту задачу:
program SumOfDigits; var n, d1, d2, sum: integer; begin writeln('Введите двухзначное число:'); readln(n); d1 := n div 10; // первая цифра числа d2 := n mod 10; // вторая цифра числа sum := d1 + d2; // сумма цифр числа if sum mod 6 = 0 then writeln('Сумма цифр числа ', n, ' кратна 6') else writeln('Сумма цифр числа ', n, ' не кратна 6'); end.
Надеюсь, это поможет вам с решением задачи.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili