Вопрос задан 24.02.2019 в 15:16.
Предмет Информатика.
Спрашивает Марвин Данил.
Программа на pascalABC нужно сделать программу и блок-схему Вычислить |7x-15|-x4 если x=-4 x=3
Напишите программу пожалуйста по школьному варианту Program var begin end.Ответы на вопрос
Отвечает Shurandina Alexandra.
Program n1;
var x: integer;
begin
x:=-4;
writeln(abs(7*x-15)-sqr(sqr(x)));
x:=3;
writeln(abs(7*x-15)-sqr(sqr(x)));
end.
var x: integer;
begin
x:=-4;
writeln(abs(7*x-15)-sqr(sqr(x)));
x:=3;
writeln(abs(7*x-15)-sqr(sqr(x)));
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам с написанием программы на языке PascalABC. Вот пример программы, которая вычисляет |7x-15|-x4 для x=-4 и x=3:
program abs; var x, y: integer; begin x := -4; // задаем значение x y := abs(7*x-15) - x*x*x*x; // вычисляем y по формуле writeln('y = ', y); // выводим y на экран x := 3; // задаем другое значение x y := abs(7*x-15) - x*x*x*x; // вычисляем y по формуле writeln('y = ', y); // выводим y на экран end.
Вот блок-схема, которая иллюстрирует алгоритм программы:
![flowchart]
Надеюсь, это поможет вам с вашим заданием.
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
