Вопрос задан 23.02.2019 в 11:35. Предмет Информатика. Спрашивает Литвинова Настя.

(30 БАЛЛОВ).Помогите написать ПРОГРАММУ ПО ИНФОРМАТИКЕ. Задана следующая задача: УДАЛИТЬ ПЕРВЫЙ

ЭЛЕМЕНТ КРАТНЫЙ ТРЕМ (В Паскале). Я плохо понимаю информатику,поэтому по возможности распишите программу целиком.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Жиряков Андрей.
Первый кратный элемент заменяется на 0
const     
n = 10; 
var   
a : array [1..n] of integer;  
 i,m : integer;  
    begin
  for i := 1 to n do 
   a[i] := i;              
 
 m := 0; 
  i := 1;
 while (m = 0)
 and (i<=n) do   
  begin  
    if a[i] mod 3 = 0 then 
      begin   
     a[i] := 0;   
     m := 1;  
     end ;  
    i := i +1; 
    end;   
 for i := 1 to n do  
  writeln (a[i]); 
  end. 
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Паскале, которая удаляет первый элемент в массиве, который кратен трём. Вот пример программы:

```pascal program RemoveMultipleOfThree;

const MaxSize = 100;

var arr: array[1..MaxSize] of integer; n, i, indexToRemove: integer;

procedure RemoveElement(var arrayToModify: array of integer; index: integer); var j: integer; begin for j := index to high(arrayToModify) - 1 do arrayToModify[j] := arrayToModify[j + 1]; SetLength(arrayToModify, high(arrayToModify)); end;

begin writeln('Введите размер массива (не более ', MaxSize, '): '); readln(n);

writeln('Введите элементы массива:'); for i := 1 to n do readln(arr[i]);

// Находим индекс первого элемента, кратного трём indexToRemove := 0; for i := 1 to n do begin if (arr[i] mod 3 = 0) then begin indexToRemove := i; break; end; end;

// Если найден элемент, кратный трём, то удаляем его if indexToRemove > 0 then begin writeln('Удаляем элемент с индексом ', indexToRemove); RemoveElement(arr, indexToRemove); n := n - 1; // Уменьшаем размер массива end else writeln('Элемент, кратный трём, не найден в массиве.');

// Выводим обновленный массив writeln('Обновленный массив:'); for i := 1 to n do writeln(arr[i]);

readln; end. ```

В этой программе мы сначала вводим размер массива и его элементы. Затем мы находим индекс первого элемента, кратного трём, и используем процедуру `RemoveElement`, чтобы удалить этот элемент из массива. После этого выводим обновленный массив.

Обратите внимание, что в Pascal индексы массивов начинаются с 1, поэтому мы использовали диапазон от 1 до MaxSize для массива `arr`.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос