Паскаль 1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число
делится на В (В вводится с клавиатуры). 2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа. Написать программу поиска таких чисел. 3. Составить программу для проверки, можно ли заданное натуральное число N представить в виде произведения двух простых чисел.Ответы на вопрос
var
a,b,sum : integer;
begin
Readln(a, b);
if (a mod b = 0) then
begin
while a > 0 do
begin
sum:= sum + (a mod 10);
a:= a div 10;
end;
if sum > b then
begin
Writeln('Верно');
halt;
end;
end;
Writeln('Неверно');
end.
Пример:
1234 2
Верно
2)
var
i: integer;
begin
For i:= 100 to 999 do
if (i*i)mod 1000 = i then Write(i, ' ');
end.
Результат:
376 625
3)
var
i,n : integer;
function Simple(n: Longint): boolean;
var
i: Longint;
begin
for i := 2 to Round(Sqrt(n)) do
if n mod i = 0 then
break;
Simple := n mod i <> 0;
end;
begin
Read(n);
For i:= 1 to Round(Sqrt(n)) do
if n mod i = 0 then
if (Simple(i))and(Simple(n div i)) then
begin
Writeln('YES');
halt;
end;
Writeln('NO');
end.
Пример:
33
YES
Паскаль 1: Проверка суммы цифр и деления на В
Для данной задачи вам потребуется написать программу на языке Паскаль. Вот пример программы, которая решает данную задачу:
```pascal program CheckNumber; var number, V, sum: integer; begin write('Введите число: '); readln(number); write('Введите значение В: '); readln(V); sum := 0; while number > 0 do begin sum := sum + (number mod 10); number := number div 10; end; if (sum > V) and (number mod V = 0) then writeln('Сумма цифр больше В и число делится на В') else writeln('Условие не выполняется'); end. ```
В этой программе мы считываем число и значение В с клавиатуры. Затем мы вычисляем сумму цифр числа, используя операции деления на 10 и взятия остатка от деления на 10. После этого мы проверяем условие: сумма цифр должна быть больше В и число должно делиться на В. Если условие выполняется, выводится сообщение "Сумма цифр больше В и число делится на В", в противном случае выводится сообщение "Условие не выполняется".
Паскаль 2: Поиск чисел, квадраты которых оканчиваются на исходные цифры
Для решения этой задачи также потребуется написать программу на языке Паскаль. Вот пример программы, которая решает данную задачу:
```pascal program FindNumbers; var number, square, lastDigits: integer; begin for number := 100 to 999 do begin square := number * number; lastDigits := square mod 1000; if lastDigits = number then writeln(number); end; end. ```
В этой программе мы перебираем все трехзначные числа от 100 до 999. Для каждого числа мы вычисляем его квадрат и берем последние три цифры этого квадрата с помощью операции взятия остатка от деления на 1000. Затем мы сравниваем эти последние три цифры с исходным числом. Если они совпадают, выводим исходное число.
Паскаль 3: Проверка представления числа N в виде произведения двух простых чисел
Для решения этой задачи также потребуется написать программу на языке Паскаль. Вот пример программы, которая решает данную задачу:
```pascal program CheckPrimeProduct; var N, i: integer; isPrime: boolean; begin write('Введите число N: '); readln(N); isPrime := true; for i := 2 to N div 2 do begin if N mod i = 0 then begin isPrime := false; break; end; end; if isPrime then writeln('Число N является простым числом') else writeln('Число N не является простым числом'); end. ```
В этой программе мы считываем число N с клавиатуры. Затем мы проверяем, является ли число N простым числом. Для этого мы перебираем все числа от 2 до N/2 и проверяем, делится ли N на каждое из этих чисел без остатка. Если N делится на какое-то число без остатка, то число N не является простым. Если после перебора всех чисел от 2 до N/2 мы не нашли делителей, то число N является простым.
Примечание: В данной программе мы проверяем только одно число N на простоту. Если вам нужно проверить несколько чисел на простоту, вы можете поместить код проверки в цикл и считывать числа N внутри цикла.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
