 
Написать программу на Си. Составить программу, определяющую, в каком из данных двух чисел больше
цифр. 0
        0
         0
        0
    Ответы на вопрос
 
        int main(void) {
int a1,a2,b,k1=0,k2=0;
printf("a1 = ");
scanf("%d",&a1);
printf("a2 = ");
scanf("%d",&a2);
if (a1>0) b=a1; else b=-a1;
while (b>0) {
k1++; b /= 10;
}
if (a2>0) b=a2; else b=-a2;
while (b>0) {
k2++; b /= 10;
}
if (k1>k2) printf("В числе %d больше цифр, чем в числе %d",a1,a2);
else if (k2>k1) printf("В числе %d больше цифр, чем в числе %d",a2,a1);
else printf("Количество цифр в числах одинаково");
return 0;
}
Пример:
a1 = 153
a2 = -4680
В числе -4680 больше цифр, чем в числе 153
 0
                    0
                     0
                    0
                 
            Программа на языке C для определения, в каком из двух чисел больше цифр
```c
#include 
int countDigits(int num) { int count = 0; while (num != 0) { num /= 10; count++; } return count; }
int main() { int num1, num2; printf("Введите первое число: "); scanf("%d", &num1); printf("Введите второе число: "); scanf("%d", &num2);
int digits1 = countDigits(num1); int digits2 = countDigits(num2);
if (digits1 > digits2) { printf("В первом числе больше цифр.\n"); } else if (digits2 > digits1) { printf("Во втором числе больше цифр.\n"); } else { printf("В обоих числах одинаковое количество цифр.\n"); }
return 0; } ```
Описание программы: - Программа запрашивает у пользователя два числа. - Затем она вызывает функцию `countDigits`, которая подсчитывает количество цифр в числе. - Результаты подсчета сравниваются, и выводится информация о том, в каком из чисел больше цифр или если количество цифр одинаково.
Пример использования программы: ``` Введите первое число: 12345 Введите второе число: 6789 В первом числе больше цифр. ```
Примечание: - Данная программа работает только с целыми числами. - Если вам нужно работать с числами, содержащими десятичные дроби, вам потребуется изменить программу соответствующим образом.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			