Вопрос задан 22.02.2019 в 21:29.
Предмет Информатика.
Спрашивает Виницкий Даниил.
Pascal. Составьте программу генерирущию одномерный массив B(N) который содержит те же элементы что
и одномерный массив A(N) но в котором отрицательные числа предшествуют неотрицательнымОтветы на вопрос
Отвечает Шиколашка Дашка.
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
var b:=(a.Where(t->t<0)+a.Where(t->t>=0)).ToArray; b.Println
end.
Пример
n= 16
19 13 8 -50 28 13 -34 -7 13 -41 37 -34 34 -23 14 21
-50 -34 -7 -41 -34 -23 19 13 8 28 13 13 37 34 14 21
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
var b:=(a.Where(t->t<0)+a.Where(t->t>=0)).ToArray; b.Println
end.
Пример
n= 16
19 13 8 -50 28 13 -34 -7 13 -41 37 -34 34 -23 14 21
-50 -34 -7 -41 -34 -23 19 13 8 28 13 13 37 34 14 21
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая генерирует одномерный массив B(N), содержащий те же элементы, что и одномерный массив A(N), но в котором отрицательные числа предшествуют неотрицательным:
```pascal program ArrayTransformation; const N = 10; // размер массива var A, B: array[1..N] of Integer; // объявление массивов i, j: Integer; // счетчики begin // Заполнение массива A случайными числами Randomize; for i := 1 to N do A[i] := Random(21) - 10; // генерация чисел от -10 до 10 // Вывод массива A WriteLn('Массив A:'); for i := 1 to N do Write(A[i], ' '); // Преобразование массива A в массив B j :=
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
