Вопрос задан 22.02.2019 в 18:08. Предмет Информатика. Спрашивает Шаулина Алина.

HELP!!!!! дан двумерный массив(4*5) написать программу, которая определит кол-во четных элементов

двумерного массива. Заполонить с клавиатуры.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дубровский Валера.
Программа внутри вложенного файла
0 0
Отвечает Аршакян Левон.
Var a:array[1..10, 1..10] of integer; 
i,j,k:integer; 
begin 
k:=0; 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
readln(a[i,j]); 
if (a[i,j] mod 2=0) then k:=k+1; 
end; 
for i:=1 to 4 do begin 
for j:=1 to 5 do 
write(a[i,j],' '); 
writeln; 
end; 
writeln('Количество четных элементов - ',k); 
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи, вам потребуется написать программу на языке программирования, которая будет запрашивать у пользователя значения элементов двумерного массива размером 4x5 и определять количество четных элементов в этом массиве.

Вот пример программы на языке C, которая решает данную задачу:

```c #include

int main() { int arr[4][5]; int count = 0;

printf("Введите элементы двумерного массива:\n");

for (int i = 0; i < 4; i++) { for (int j = 0; j < 5; j++) { printf("arr[%d][%d]: ", i, j); scanf("%d", &arr[i][j]); } }

for (int i = 0; i < 4; i++) { for (int j = 0; j < 5; j++) { if (arr[i][j] % 2 == 0) { count++; } } }

printf("Количество четных элементов в двумерном массиве: %d\n", count);

return 0; } ```

Программа создает двумерный массив `arr` размером 4x5 и запрашивает у пользователя ввод элементов этого массива. Затем она проходит по всем элементам массива и считает количество четных элементов. Наконец, программа выводит полученный результат.

Примечание: В данном примере используется язык программирования C. Если вам нужно решение на другом языке программирования, пожалуйста, уточните это.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос