Напишите пожалуйста программу С клавиатуры вводится N целых чисел, Nтоже вводится с клавиатуры.
Найти сумму нечетных, оканчивающихся на 7 или сообщить, что таких чисел в введенной последовательности нетОтветы на вопрос
begin
write('n = ');
readln(n);
s:=0; f:=0;
for i:=1 to n do
begin
readln(a);
if abs(a) mod 10 = 7
then begin s:=s+a; f:=1; end;
end;
if f=1
then writeln('Сумма нечетных чисел, оканчивающихся на 7 = ',s)
else writeln('среди введенных чисел нет нечетных, оканчивающихся на 7');
end.
Пример:
n = 5
25
-17
71
68
27
Сумма нечетных чисел, оканчивающихся на 7 = 10
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger(ReadInteger).Where(m->abs(m) mod 10=7).ToArray;
if a.Length=0 then Writeln('Нет чисел, оканчивающихся на 7')
else Writeln('Сумма чисел, оканчивающихся на 7: ',a.Sum)
end.
Пример
5
16 37 3 7 -27
Сумма чисел, оканчивающихся на 7: 17
Программа на C для нахождения суммы нечетных чисел, оканчивающихся на 7
Для решения этой задачи мы можем написать программу на языке C, которая будет принимать ввод от пользователя, находить сумму нечетных чисел, оканчивающихся на 7, и выводить результат.
```c
#include
int main() { int n, num, sum = 0;
printf("Введите количество чисел: "); scanf("%d", &n);
for (int i = 0; i < n; i++) { printf("Введите число %d: ", i + 1); scanf("%d", &num); if (num % 2 != 0 && num % 10 == 7) { sum += num; } }
if (sum != 0) { printf("Сумма нечетных чисел, оканчивающихся на 7: %d\n", sum); } else { printf("В введенной последовательности нет таких чисел\n"); }
return 0; } ```
Эта программа сначала запрашивает у пользователя количество чисел (N), затем просит ввести сами числа. После этого она находит сумму нечетных чисел, оканчивающихся на 7, и выводит результат. Если в последовательности нет таких чисел, программа сообщит об этом.
Пример работы программы:
``` Введите количество чисел: 5 Введите число 1: 17 Введите число 2: 25 Введите число 3: 12 Введите число 4: 37 Введите число 5: 40 Сумма нечетных чисел, оканчивающихся на 7: 54 ```
В этом примере программа принимает 5 чисел от пользователя, находит сумму нечетных чисел, оканчивающихся на 7 (17 и 37), и выводит результат.
Объяснение программы:
1. Программа сначала запрашивает у пользователя количество чисел (N) с помощью `printf` и `scanf`. 2. Затем она входит в цикл `for`, в котором запрашивает у пользователя каждое число и проверяет, является ли оно нечетным и оканчивается ли на 7. Если условие выполняется, число добавляется к переменной `sum`. 3. После завершения цикла программа проверяет, была ли найдена хотя бы одна такая сумма. Если да, она выводит сумму, иначе сообщает, что таких чисел в последовательности нет.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
