написать программу на c++, которая переводит число из двоичной системы счисления в десятичную
Ответы на вопрос
#include <iostream>
#include <string>
#include <cmath>
using namespace std;
void main(void){
setlocale(LC_ALL, "rus");
int i,sum=0,n,r=0;
char date[255];
cout << "Введите двоичное число"<< endl;
cin >> date;
n = strlen(date);
int *arr = new int[n];
for (i = 0; i < n; i++){
arr[i] = (int)date[i] - (int)'0';
}
for (i = 0; i < n; i++){
cout << arr[i] << " ";
}
cout << " " << endl;
for (i = 0; i < n; i++){
r = r + arr[i]*pow(2, n - i-1);
}
cout << "Десятичное число равно" << r;
}
Программа на C++ для перевода числа из двоичной системы счисления в десятичную
Вот пример программы на C++, которая переводит число из двоичной системы счисления в десятичную:
```cpp
#include
int binaryToDecimal(int binaryNumber) { int decimalNumber = 0; int base = 1; int temp = binaryNumber; while (temp) { int lastDigit = temp % 10; temp = temp / 10; decimalNumber += lastDigit * base; base = base * 2; } return decimalNumber; }
int main() { int binaryNumber; cout << "Введите число в двоичной системе счисления: "; cin >> binaryNumber; int decimalNumber = binaryToDecimal(binaryNumber); cout << "Число в десятичной системе счисления: " << decimalNumber << endl; return 0; } ```
В этой программе мы используем функцию `binaryToDecimal`, которая принимает число в двоичной системе счисления и возвращает его эквивалент в десятичной системе счисления. В основной функции `main` мы сначала запрашиваем у пользователя число в двоичной системе счисления, затем вызываем функцию `binaryToDecimal` и выводим результат.
Пример работы программы: ``` Введите число в двоичной системе счисления: 10101 Число в десятичной системе счисления: 21 ```
Примечание: Проверьте код программы на своей среде разработки, чтобы убедиться, что он работает должным образом.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
