Вопрос задан 20.02.2019 в 23:49. Предмет Информатика. Спрашивает Головина Вика.

Написать программу вычисления количества ненулевых элементов одномерного массива. В C++

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Афонченко Антоний.
#include <iostream>
using namespace std;

int main(){
    int ar[10];
    int k=0;
    for(int i=0;i<10;i++){
            cin>>ar[i];
            if(ar[i]!=0)
              k++; 
             }
     cout<<k;
     cin.get();
     cin.get();
}

Пример ввода:
1
0
0
0
0
1
1
1
1
Пример вывода:
6
0 0
Отвечает Цаплин Всеволод.
#include <cstdlib>#include <iostream> using namespace std; void MassNullEllement(int *Mass){     int KolEl = 0 ;     for(int a=0;a<5;a++){        if(Mass[a]!=0){KolEl++;}        }     cout<<"amount element not equal zero = "<<KolEl<<"\n";    } int main(int argc, char *argv[]){    int Massiv[5];    for(int b=0;b<5;b++){            cout<<"Enter "<<b<<" element - ";
cin>>Massiv[b];           }   MassNullEllement(Massiv);    system("PAUSE");    return EXIT_SUCCESS;}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке C++, которая вычисляет количество ненулевых элементов в одномерном массиве:

```cpp #include

int countNonZeroElements(int arr[], int size) { int count = 0; for (int i = 0; i < size; i++) { if (arr[i] != 0) { count++; } } return count; }

int main() { int arr[] = {1, 0, 3, 0, 5, 0, 7}; int size = sizeof(arr) / sizeof(arr[0]);

int nonZeroCount = countNonZeroElements(arr, size);

std::cout << "Number of non-zero elements: " << nonZeroCount << std::endl;

return 0; } ```

В этом примере мы определяем функцию `countNonZeroElements`, которая принимает массив и его размер в качестве аргументов. Функция проходит по каждому элементу массива и увеличивает счетчик, если элемент не равен нулю. Затем функция возвращает количество ненулевых элементов.

В функции `main` мы создаем массив `arr` и определяем его размер. Затем мы вызываем функцию `countNonZeroElements`, передавая ей массив и его размер. Результат сохраняется в переменной `nonZeroCount`, которую мы выводим на экран.

Примечание: В этом примере мы предполагаем, что массив содержит только целые числа. Если вам нужно работать с другим типом данных, вам нужно будет изменить тип аргументов функции и тип элементов массива.

Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос