Помогите плииз написать программу на паскале определить, поступит или нет абитуриент в ВУЗ, если
известны его оценки за 4 экзамена и проходной балл поступления в ВУЗ.Ответы на вопрос
a,b,c,d,e:real;
begin
writeln('Введите проходной бал');
readln(e);
writeln('Введите оценку за 1-й экзамен');
readln(a);
writeln('Введите оценку за 2-й экзамен');
readln(b);
writeln('Введите оценку за 3-й экзамен');
readln(c);
writeln('Введите оценку за 4-й экзамен');
readln(d);
if a+b+c+d>=e then
writeln('Поступит')
else
writeln('Не поступит');
end.
Конечно, я могу помочь вам написать программу на языке Паскаль, которая будет определять, поступит ли абитуриент в ВУЗ, если известны его оценки за 4 экзамена и проходной балл поступления в ВУЗ.
Вот пример программы на Паскале:
``` program Admission; var grade1, grade2, grade3, grade4, passingScore: integer; average: real; begin writeln('Введите оценки за 4 экзамена:'); readln(grade1, grade2, grade3, grade4); writeln('Введите проходной балл поступления в ВУЗ:'); readln(passingScore); average := (grade1 + grade2 + grade3 + grade4) / 4; if average >= passingScore then writeln('Абитуриент поступит в ВУЗ.') else writeln('Абитуриент не поступит в ВУЗ.'); end. ```
В данной программе мы сначала запрашиваем оценки за 4 экзамена у пользователя, а затем проходной балл поступления в ВУЗ. Затем мы вычисляем средний балл абитуриента, суммируя оценки и деля их на 4. После этого мы сравниваем средний балл с проходным баллом. Если средний балл больше или равен проходному баллу, то выводим сообщение "Абитуриент поступит в ВУЗ", иначе выводим сообщение "Абитуриент не поступит в ВУЗ".
Надеюсь, данная программа поможет вам решить вашу задачу.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
